Mailchannels IIncident
Resolved
Jan 10 at 08:31am UTC
We have implemented a local fix and mail services should be back to normal. Mail queues might delay deliverability for some time.
Affected services
IMAP Business Email UAE - IMAP Servers (Incoming Mailservers):993
SMTP Business Email UAE - SMTP Servers (Outgoing Mailservers):587
Created
Jan 10 at 06:48am UTC
Mailchannels, the provider of our Antispam Soplution is facing a global DNS propagation issue resulting in mails not being delivered (in and outgoing). We are waiting for them to give us a final time for the resolution.
You can also check their Status Page for updates. Please not this is not related to your mail services so do not change any settings. Once they fix the issue mails will work as expected.
Affected services
IMAP Business Email UAE - IMAP Servers (Incoming Mailservers):993
SMTP Business Email UAE - SMTP Servers (Outgoing Mailservers):587