Maintenance Work
Incident Report for Bamboozle Web Services Inc.
Resolved
This incident has been resolved.
Posted almost 2 years ago. Apr 23, 2017 - 05:35 GMT+04:00
Identified
Certain Networks might be done for upgrades. We expect the Service Window to be from 0:00 - 3:00am GST.
Posted almost 2 years ago. Apr 23, 2017 - 02:17 GMT+04:00