Bamboozle Billing Portal down for maintenance.
Incident Report for Bamboozle Web Services Inc.
Resolved
Our upgrades are completed.
Posted over 2 years ago. Nov 12, 2016 - 19:22 GMT+04:00
Investigating
We are upgrading our portal. For support tickets, please send an email to support@bamboozle.me, it will autoamtically logged.
Posted over 2 years ago. Nov 12, 2016 - 14:36 GMT+04:00