Mail Services Maintenance
Incident Report for Bamboozle Web Services Inc.
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 01, 2018 - 03:47 GMT+04:00
Monitoring
We are updating our Mail Services. In the time of the update, mail services can be unreachable for some time.
Posted over 1 year ago. Feb 28, 2018 - 23:07 GMT+04:00