Component Update
Incident Report for Bamboozle Web Services Inc.
Resolved
This incident has been resolved.
Posted almost 3 years ago. Oct 14, 2016 - 23:21 GMT+04:00
Identified
We are updating our Infrastructure. Our Services will be offline for approximately 60 minutes.
Posted almost 3 years ago. Oct 14, 2016 - 20:15 GMT+04:00