Cloud Maintenance
Incident Report for Bamboozle Web Services Inc.
Resolved
This incident has been resolved.
Posted over 1 year ago. Sep 29, 2017 - 10:21 GMT+04:00
Monitoring
We are performing maintenance works on Cloud DBX01. No downtime of services is expected but control panel might be unreachable for some time.
Posted over 1 year ago. Sep 28, 2017 - 12:30 GMT+04:00